Author Topic: Sound problems... !!!  (Read 4288 times)

matlu

  • Administrator
  • Commander
  • *****
  • Posts: 1390
    • Email
Sound problems... !!!
« on: May 03, 2005, 10:36:43 am »
I'm trying to make sounds for the game (for the beginning just "beep" sound when you click some button), but I run into a serious problem.

When I try it from Windows 98, with microsoft's Java, it works without problem. From Windows XP and Sun's java, EVERY sound is delayed by approx. 1 or 2 seconds. (It is played later as it should).
The problem is probably not in operating system, but in java version.

Had anybody similar problem with cyberwars, or other jagex game?

matlu

  • Administrator
  • Commander
  • *****
  • Posts: 1390
    • Email
Re: Sound problems... !!!
« Reply #1 on: May 03, 2005, 01:19:33 pm »
So, after WHOLE day of testing / tinkering / tweaking / crashing head against the wall I managed to get it working SOMEHOW. However it is possible that it will NOT work on all platforms. (java's sound support is terrible)

- you should hear clean "beep" sound when you click any button

- PLEASE report problems - if you hear some scratches, noises etc
- PLEASE if you have some other operating system than MS Windows, OR some other browser than Internet Explorer report ANYWAY (even if it works)

matlu

  • Administrator
  • Commander
  • *****
  • Posts: 1390
    • Email
Re: Sound problems... !!!
« Reply #2 on: May 03, 2005, 01:40:39 pm »
So, my own report: on Windows XP with Sun's java, sound simply STOPS working after sever minutes of playing. No idea why.
(I HATE such problems :(  )

flamingdragon

  • Commander
  • *****
  • Posts: 3934
    • Email
Re: Sound problems... !!!
« Reply #3 on: May 03, 2005, 05:11:04 pm »
I have XP. The sound on the game is working fine for me.
Adun Toridas, Executor.


raikoukami

  • Alien
  • **
  • Posts: 61
Re: Sound problems... !!!
« Reply #4 on: June 04, 2005, 11:31:51 pm »
sound is working for me also.

Bakster

  • Commander
  • *****
  • Posts: 1841
    • Email
Re: Sound problems... !!!
« Reply #5 on: June 27, 2005, 02:27:54 pm »
When I'm playing cyber battles, and some other sound source like MSN comes up, the sound on the game stops.

I don't know if this is a problem with my machine or not.

I use IE, and Windows 98.